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shipped may effect its performance and cause interference with other apparatus in the immediate
vicinity. If such interference is detected, suitable mitigating measures should be taken.

SofTec Microsystems

E-mail (general information): info@softecmicro.com

E-mail (marketing department): marketing@softecmicro.com
E-mail (technical support): support@softecmicro.com

Web: http://www.softecmicro.com

Important

SofTec Microsystems reserves the right to make improvements to USBSPYDERO8, its documentation and software routines,
without notice. Information in this manual is intended to be accurate and reliable. However, SofTec Microsystems assumes no
responsibility for its use; nor for any infringements of rights of third parties which may result from its use.

SOFTEC MICROSYSTEMS WILL NOT BE LIABLE FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF
PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF.
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1 Overview

1.1 What is USBSPYDERO08?

The USBSPYDERO8 Discovery Kit is a USB-based in-circuit debugger
specific for Freescale MCORS08KA, MC9S08QD and MC9S08QG
microcontrollers.

USBSPYDERO08 comes with a MC9RS08QG4 microcontroller mounted on
its 8-pin socket. Thanks to the built-in BDM connector, USBSPYDEROS is
able to debug external MC9RS08KA, MC9S08QD and MC9S08QG devices
in any package.

USBSPYDERQO0S takes advantage of the CodeWarrior Development Studio
Special Edition (which groups an Editor, Assembler, C Compiler and
Debugger) and the Freescale BDM interface, which allows the download and
debug of the user application into the target microcontroller’'s Flash memory.

Together with CodeWarrior, USBSPYDEROS8 provides you with everything
you need to write, compile, download, in-circuit emulate and debug user
code. Full-speed program execution allows you to perform hardware and
software testing in real time.

USBSPYDERO0S8 offers you the following debugging features:

= Real-time code execution and in-circuit debugging;
=  Working frequency up to 10 MHz;

=  Socketed target microcontroller;

=  BDM connector for external debugging;

= 3.3V devices supported;

= Jumperless hardware mode setting;

=  USB connection to the PC;

= CodeWarrior IDE (the same user interface of all Freescale tools), with
editor, assembler, C compiler and debugger.
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1.2 Package Contents

The USBSPYDERO8 package includes the following items:

= USBSPYDEROS in-circuit debugging unit;

= USBSPYDERO08 CD-ROM with CodeWarrior Development Studio
Special Edition, SofTec Microsystems Additional Components and
documentation.

1.3 Supported Devices

USBSPYDERO08 supports the following devices:

= MC9RSO08KA family;
] MC9S08QD family;
] MC9S08QG family.

The on-board socket accepts 8-pin devices, while the provided BDM
connector can be used to work with external devices in any package.

Before working with an external target device, you must remove the target
device mounted on the on-board socket.

1.4 Hardware Overview

The USBSPYDERO08 Discovery Kit features:

1. A built-in USB to BDM circuitry (based on Freescale MC68HC908JB16
microcontroller) which allows the host PC to communicate with the
target microcontroller through a standard USB interface;

2. A MC9RSO08KA, MC9S08QD or MC9S08QG target microcontroller in 8-
pin DIP package, already programmed with a demo application;

3. A provision for a header connector with all of the microcontroller
signals;

4. A BDM connector for debugging external devices.
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The following figure shows the various USBSPYDERO8 connectors.

On-Board Target Device

USB Connector
User LED

BDM Connector for External Debugging

USBSPYDERO8 Connectors

1.4.1 USB Connector

The USB connector is used to connect USBSPYDERO0S to the host PC.
USBSPYDERO08 is powered by the USB bus voltage.

1.4.2 BDM Connector

USBSPYDERO08 uses a variation of the standard, 6-pin BDM connector
defined by Freescale to program and debug external MCORSO08KA,
MC9S08QD and MC9S08QG devices, in any package.
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1 2
BKGD GND
NC RSTIVPP
NC VDD
5 6

BDM Connector

Pin Signal Name Description

1 BKGD Single-wire background interface pin.

2 GND System ground.

3 NC Not connected.

4 RST#/VPP Reset signal to target system, or Vpp.

5 NC Not connected.

6 VDD By default, this signal is not used by USBSPYDERO8. If you want

to enable this line, you must solder the 0 Ohm R2 resistor (the
provision for the R2 resistor is placed near the BDM connector).
With the resistor soldered, the VDD line will supply a power
voltage to the target (3.3 V). This is used to power on/off the target
microcontroller in order to force a background monitor mode entry
when the RST pin is not available.

BDM Connector Signals

Note: before working with an external target device, you
must remove the target device mounted on the on-board
socket.
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1.5 Software Overview

1.5.1 CodeWarrior Development Studio Special Edition

USBSPYDERO08 comes with CodeWarrior Development Studio Special
Editions for HC(S)08.

CodeWarrior Development Studio is a powerful and easy-to-use tool suite
designed to increase your software development productivity. Its Integrated
Development Environment (IDE) provides unrivaled features such as
Processor Expert application design tool, full chip simulation, Data
Visualization and project manager with templates to help you concentrate on
the added value of your application.

The comprehensive, highly visual CodeWarrior Development Studio for
Freescale Microcontrollers enables you to build and deploy Freescale
systems quickly and easily. This tool suite provides the capabilities required
by every engineer in the development cycle, from board bring-up to firmware
development to final application development.

Without a license key, the product will run in a 1 KB code-size limited
demonstration mode.

To break the 1 KB limit, you have two options:

1. Contact Freescale to request an unlimited period, free license key to
increase the code size limit to 16 KB;

2. Contact Freescale to request a 30-day limited, free license key to run
the compiler without limitations.

This documentation covers the basic setup and operation of CodeWarrior
Development Studio, but does not cover all of its functions. For further
information, please refer to the CodeWarrior on-line help and on-line
documentation provided.

1.6 Getting Device Samples

You can obtain free device samples by ordering directly on
www.freescale.com.
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1.7 Recommended Reading

This documentation describes how to use the USBSPYDERO08 Discovery Kit
and how to set up basic debugging sessions with CodeWarrior. Additional
information can be found in the following documents:

] CodeWarrior additional documentation—available from the
CodeWarrior IDE.

=  Freescale datasheets.
=  Freescale application notes.

10
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2 Quick Start Guide

2.1 Software Setup

PC, it is recommended that you install all of the required
software first (see below), so that the USBSPYDERO08 USB
driver will be automatically found by Windows when you
connect the board.

ﬁ Note: before connecting the USBSPYDERO8 board to the

2.1.1 Host System Requirements

The following hardware and software are required to run the CodeWarrior
user interface together with USBSPYDERO08:

1. A 500-MHz (or higher) PC compatible system running Windows 98,
Windows 2000 or Windows XP;

2. 256 MB of available system RAM plus 1 GB of available hard disk
space;

3. A USB port;

4. CD-ROM drive for installation.

2.1.2 Software Setup

Note: to install the USBSPYDEROS8 software on Windows
2000 or Windows XP, you must log in as Administrator.

1. Insertthe USBSPYDERO08 CD-ROM into your computer's CD-ROM
drive. A startup window will automatically appear.

11
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2. Choose “Install CodeWarrior” and follow the on-screen instructions.

3. Choose “Install SofTec Microsystems Additional Components” and
follow the on-screen instructions.

2.2 PC Connection

After installing the software, you can plug USBSPYDEROS8 into a USB port
on your PC.

USBSPYDERO0S8 is powered by the USB bus voltage, and requires a USB
port capable of supplying 200 mA.

The first time USBSPYDEROS is connected to the PC, Windows recognizes
the instrument and starts the “Found New Hardware Wizard” procedure,
asking you to specify the driver to use for the instrument.

1. On Windows XP (SP2) the following dialog box will appear, asking you
to search for a suitable driver on the web.

Found Mew Hardware Wizard

Welcome to the Found New
Hardware Wizard
“Windows will ssarch for curent and updated software by

Inoking on your computer, on the hardware installation CO. or on
the Windows Update ‘web site [with your permissian).

Fiead our privacy policy

Can windows connect ta Windows Update to search for
software?

(O Yes. this time only

(O res, now and every time | connect a device

() Mo, not this time

Click MNext to continue.

New Hardware Wizard, Step 1

Select the “No, not this time” option and click the “Next >" button.
2. The following dialog box will appear.

12
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Found New Hardware Wizard

. This wizard helps you install software for:
USBSPYDERDE 2

'\'_) If your hardware came with an installation CD
S4B o floppy disk. insert it now.

‘what do you want the wizard to da?

(® Install the software automatically [Recommended)
) Install irom a list or specific location (Advanced)

Click Mext to continue.

l < Back “ Nest » 1[ Cancel

New Hardware Wizard, Step 2

Click the “Next >" button.

3. Windows will install the driver files to your system. At the end of the
installation, the following dialog box will appear.

Found New Hardware Wizard

Completing the Found New
Hardware Wizard

The wizard has finished installing the software for:

g USESPYDEROS

Click Finish to close the wizard,

New Hardware Wizard, Step 4

Click the “Finish” button to exit from the “Found New Hardware
Wizard” procedure.

4. The USBSPYDERO08 USB driver is now installed on your system.

13
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2.3 Moving Your First Steps with CodeWarrior

1. Start CodeWarrior Development Studio by selecting it in the Windows
Start menu.

2.  Open the USBSPYDERO08 back cover in order to expose the socketed
microcontroller.

3. Read the microcontroller code and, from the CodeWarrior main menu,
choose “File > Open” and select the “demo.mcp” project for your
specific microcontroller. Projects are placed:

= Under the “\Program Files\Freescale\CodeWarrior for HC0O8
V5.1\(CodeWarrior Examples)\HCS08\Evaluation Board
Examples\USBSPYDEROQOS8\" directory for HCS08 devices (QD,
QG);

= Under the “\Program Files\Freescale\CodeWarrior for HC08
V5.1\(CodeWarrior Examples)\RS08\Evaluation Board
Examples\USBSPYDERO08\" directory for RS08 devices (KA).

4. Click “Open”. The “Project” window will open.

5. The code of this example is contained in either the “main.c” or
“main.asm” file. Double click on it to open it.

14
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B Freescale CodeWarrior - [main.c] = <]

B Fle Edit View Search Project ProcessorExpert Device Initisization Window Help

Masnecxha@hdedhsnER

NI

= b g}« M- B~ o - Pabk [T Progan Fies\Fresscals\Codewariorfor HEOVE 1\Codewatior_Evamples HCS E vakuaion \nainc. <>
P
[ D serm=chcsos Ry B, 77 3508064 sample for USBSPYDERDS
v
Files ILmk Order | Targets | /7 This program continuously blinks the USBSPYDER0S LED
s
¢ Fie | Code | Data |4 |- s
¥ &350 0 0+ =~ I
M1 k 0+ =| 7 This project has besn written for CodeVarrior §.1 for HO(S)08
s+ and uses Registers Files MC9S08QG4 H and MCIS08QG4 .C, versiom 2 87 085
# 3 Includes 0 0 = 7
¥ m Libs 0 0+ o
¥ [+ Project Settings 0 0+

7 Copyright (c) 2006 SofTec Microsystens
/7 hitp: 7 wws.sof teenicro. con
o

D vy

#include <hidef .h>
#include "derivative h”

#define FREQ_EUS 8000000 ~# & MHz

#define NUM_BUS_CYCLES (FREQ_EDS » 100)/1000000

#dsfins DELAY_X_VALUE (¢ (FUM_BUS_CYCLES - 6)*10)/4)+5)¢10)-1
#define DELAY_TIME 500 4/ ns

»/ ICSTRH location in Flash
unsigned char ICSTRM_FLASH @0=FFAF:

/ Flash security (NVOPT Register)
const unsigned char FLASH SECURITY @OxFFEF - 0xFE:

LIIISIIIII LIS AP IR PIISIIISIS SIS SIS AISS L SIS SIS LTSS SRS S FISRLISSSSISIIISR I IS RS SRS SIS IS5 S =
/7 PeriphInit
v

#7 Initislizes variows registers snd peripherals
SPIIIIIITIIIIAIIR PSS LIS IIIIIIIS SIS S LIS LTSI TIIS SIS S FISELIS LSS TISSSELISSISRLSISISS SIS S
void PeriphInit{void)

{
// Dissbles COP
SOPT1 &= 0x7F;

/7 Configures PTAD as output LED
ETAD = 0x00;
PTADD = 0x01:

/7 Configures ICS clock. Selscts FLL Engaged Internal Mode (Divides ICSOUT by 1)
s« fBUS about 8 NHz

ICSTRM = ICSTRM_FLASH:

1CSC2 = 0=00:

ICSC1 = 0x04;
47 Vaits until output FIL is selected [CIKST=00)
while (ICSSC & 0x0C)

& +

Sfies ] 0
<l m 0] et cat 14y

Nafl

CodeWarrior Editor

From the main menu, choose “Project > Debug”. This will compile the
source code, generate an executable file and download it to
USBSPYDERO8. A new debugger environment will open.

15
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£, True-Time Simulator & Real-Time Debugger  C:\Program Files\Freescale\CodeWarrior for HCOB V5.11(CodeWarrior_Examples \HCS08\Evaluation Board Examples\US... |- |(0JEd
File Yiew Run SofTec-HCS0B Component  Memory ‘Windew Help

|=a] cee] 2| »|=|z]4l=(-] 2

5] I =0 < i =23
C:APiogram FlesFrees cale\Codsw/anior for HCOB V5 15(Codebw/arror_ExampleshHES 08\, Amain Line: 78 main
I [ FOBC ATS  #-2 =]
/7 Entry point FOBE CLI
L N L D N N FOBF BSR  %-45 sabe = OXFO92
woid HAiH(void] FOCL 1DA  Ox0D
18 FOC3 EOR 4001
unsigned int i FOCS 5TA  Ox0O
FOCT TEX
EnableInterruptsas FOCS CLR 1%
PeriphInit(); FOCA CIR X
FOCB 1DA  #0x0k (=
for(::) J/ Forever FOCD BSR %30 sebs = OHFOAF =)
® El
/# Toggles LED = =1
PTAD *= OxOL: =)<
/¢ Uaits 500 ms oo i
£or (i=0: i<DELAY TIME: i+l ) A 5
@] =~ |\OJgd || m= [Foo0 se [ 12F
sR [6A  status [vHINZC
2c [FoBC
main (]
O [y AEX]
main.c Auto | Synb | Global Auto
ICSTEM FLASH 151 unsigmed char #|llooso 54 E7 Fa k7 7B BF 8B FF (o]
FLASH_SECURITY 254 const unsigned char =|llonss 54 85 04 sD 0k 86 03 83 .. B
_SOPTL <1> volatile SOPTISTR 0030 ZF DF 77 27 97 85 09 SF /.
& _PTAD <1> volatile PTADSTR 0098 10 95 BA 64 20 00 44 40 ..
ZPTADD <1> volatile PTADDSTR 00AQ CC F7 FE BA DF 94 FF FB
1SRN <1> volatile ICSTRUSTR 00A8 00 03 9D 6E 05 10 AL 58
Trescz &5 volatile IC5C25TR [w]|Joom0 05 58 B0 c5 EF 6D oE ™
-0 | = B=X
main Auto | Symb | Loal STARTED [a]
1 61569 wisigued int RUMNTHG
Breakpoint
- E|
[v]
&) (Y]
For Help, press Fi Automatic (tiggers, breakpoints, watchpoints, and trace possible) MC35080a1 Breakpoint

CodeWarrior Debugger

7. From the main menu, choose “Run > Start/Continue”. The program
will be executed in real-time and will blink the USBSPYDERO8 LED.

8. To stop the program execution, from the main menu choose “Run >
Halt”.

9.  You can now continue to experiment with the CodeWarrior user
interface and discover its potentialities (step commands, breakpoints,
watch windows, etc.) on your own. Please also read carefully the
additional documentation provided in the USBSPYDERO08 CD-ROM.

16
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3 Debugging

3.1 USBSPYDERO8 Working Principles

USBSPYDERQO0S8 is an in-circuit debugger—it programs files into the target
microcontroller and offers debugging features like real-time code execution,
stepping, and breakpoints. Its debugging features are achieved thanks to the
microcontroller’s integrated Background Debug Module, BDM (also referred
to as Background Debug Controller, BDC).

The BDM peripheral communicates with the host PC board through a
dedicated, single-wire line (BKGD) of the microcontroller. The same line is
also used during device programming.

Contrariwise to traditional in-circuit emulation (where the target application is
executed and emulated inside the emulator), USBSPYDERO8 uses the very
same target microcontroller to carry on in-circuit execution. This means that
all microcontroller’s peripherals (timers, A/D converters, I/O pins, etc.) are
not reconstructed or simulated by an external device, but are the very same
target microcontroller’s peripherals. Moreover, the USBSPYDERO0S8
debugging approach ensures that the target microcontroller’s electrical
characteristics (pull-ups, low-voltage operations, I/O thresholds, etc.) are
100% guaranteed.

3.2 Working with CodeWarrior

3.2.1 Using the Project Wizard to Create Your Application Skeleton

CodeWarrior helps you get started with your own application by including a
project wizard specific for USBSPYDERO08.

To create a new project with CodeWatrrior for the devices supported by
USBSPYDEROS:

1. From the main menu, select “File > New Project...”.

17
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2. Adialog box will appear. Choose your target device and select “ SofTec
HCS08" as connection.

3. Follow the remaining Project Wizard steps.

3.2.2 Starting your First Debugging Session

The first time you enter a debugging session (by selecting “Project >
Debug” from the CodeWarrior’'s main menu) the “ Target Connection”
dialog box will open, asking you to select the debugging hardware
connected to the PC. Make sure that the hardware code is set to
“USBSPYDERO08".

Target Connection
Hardware Model
Code: [USBSPYDERDE ~|
Cancel
Freescale Starter Kit
Device
Device code:
|MC35 08064 ~l
Cammunication Settings ‘
(o)
o

The “Target Connection” Dialog Box

3.3 Notes and Tips

3.3.1 Entering Debug Session with CodeWarrior

When entering a debug session, the target microcontroller's Flash memory is
automatically erased, unsecured, programmed with the user application, and
the trimming value (if trimming is available for the selected microcontroller) is
automatically calculated and programmed (in the location suggested by
Freescale).

18
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application (after having unsecured the device),
CodeWarrior ignores (doesn’t program) the security bits. As
a result, when entering a debug session, the device is
always unsecured, regardless of other user settings.

a Note: When programming the microcontroller with the user

3.3.2 Reading Peripheral Status

Care must be taken when reading some peripheral’s status/data registers,
since a reading operation may cause the clearing of flags. This may happen
when the “Memory” window or the “Data” window is open, since these
windows read microcontroller’s resources during refresh operations.

3.3.3 Breakpoints and Trace

CodeWarrior offers a variety of tools for analyzing the program flow:
breakpoints (both simple and complex), watchpoints and a trace buffer. All
these features are implemented by taking advantage of the target
microcontroller's debug peripheral.

3.3.4 Breakpoints and BGND Instruction

The BGND Assembly instruction forces the target microcontroller to enter the
Active Background Debug mode, stopping program execution. CodeWarrior
recognizes this event as a breakpoint and updates the contents of registers,
memory, etc. Successive commands (Start/Continue, Single Step, etc.) will
continue the execution of the program from the next instruction.

the Step Over and Step Out commands (both in a C and
Assembly source code) use one hardware breakpoint.

c Note: the Single Step command (in a C source code) and

19
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3.3.5 Real-Time Memory Update

During program execution, it is possible to view/edit the contents of the
“Memory” window and “ Data” window in real time (edit operations are only
available for RAM locations). For example, it is possible to set the periodical
refresh of the “Memory” window contents by choosing “Mode >
Periodical” from the pop-up menu which appears by right-clicking on the
“Memory” window.

20
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4 Connecting to an External
Target Board

4.1 Overview

Thanks to the built-in BDM connector, USBSPYDEROS is able to debug
external MCORS08KA, MC9S08QD and MC9S08QG devices in any
package. However, only 3.3 V devices are supported.

4.2 Connection Steps

To use USBSPYDEROS to debug an external target device, follow the steps
below.

1. Remove the target device mounted on the USBSPYDERO8 on-board
socket.

2. Use a 6-way flat cable to connect from the USBSPYDER08 BDM
connector to your target board’s BDM connector.

3. Make sure that CodeWarrior is set to use the correct target device.

4. USBSPYDERO0S8 can use the VDD line of the BDM connector to
automatically power on/off the target device as necessary during
debugging. This is useful in order to force a background monitor mode
entry when the RST pin is not available. If you want to enable this line,
you must solder the 0 Ohm R2 resistor (the provision for the R2 resistor
is placed near the BDM connector).

21






USBSPYDEROS8 User's Manual

5 Troubleshooting

5.1 Common Problems and Solutions

This section reports some common problems that may arise during general
use. Please be aware, however, that working with a specific target device
may cause device-specific issues.

5.1.1 USB Driver Problems

If you connected USBSPYDERO0S8 to the PC before installing the 5
USBSPYDERQO0S8 utilities, the instrument’s USB driver may not have been

correctly installed on your system. Unplugging and replugging the USB cable

is of no use, since Windows has marked the device as “disabled”. As a

consequence, the PC cannot communicate with USBSPYDEROS.

To restore the USB driver (provided the USBSPYDEROS utilities have been

installed), perform the following steps under Windows XP:

Connect USBSPYDERO8 to the PC.

Open the Control Panel (“ Start > Settings > Control Panel”).
Open the “System” options.

Select the “Hardware” tab.

Click the “Device Manager” button.

The “USBSPYDERO08” device will be shown with an exclamation mark
next to it. Double click on this device.

7. Inthe “General” tab, click the “Reinstall Driver” button. Follow the on-
screen instructions.

o0k whPE

5.1.2 Communication Can't Be Established with USBSPYDEROQS8

1. If you use USBSPYDERO0S to debug an external device, make sure that
the target board is powered on and the target microcontroller is working.
Programming and debugging rely on a BDM communication between
USBSPYDEROS8 and the target board. This means that, in order to work

23
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correctly, the target microcontroller must be running. In particular, make
sure that:

= The BDM cable is connected to the target board.

= All of the required BDM signals are correctly tied to the target
microcontroller.

Make sure you are working with the correct hardware model. To
view/change the hardware model in use in CodeWarrior, choose
“Target Connection” from the “SofTec-HCS08” or “ SofTec-RS08”
menu (depending on the target device currently selected) in the
CodeWarrior debugger window.

5.1.3 CodeWarrior-Specific: Stepping Execution is Slow

When the “Memory” window is open, step commands may execute slower,
since the “Memory” window contents need to be refreshed after every step.

24
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6 Technical Specifications

Parameter Value

General

Operating Voltage 5V DC (provided by the USB bus)
Power Consumption 200 mA (max)

BDM Section

BDM connector VDD out signal (pin 6) 3.3V DC, 100 mA max

BDM connector BKGD out signal (pin 1) 10 MHz max at 3.3 V DC

BDM connector VPP out signal (pin 4) 12 V DC, 10 mA max

Electrical Specifications

Parameter Value

Dimensions 83 x 28 x 20 mm

BDM connector type 6-pin, 2.54-mm pitch, dual row header (male)
Operating temperature 0°C to 50°C

Storage temperature 0°C to 70°C

Humidity 90% (without condensation)

Physical and Environmental Specifications

25
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