Biobug.org

Projects, notes, etc by Will O’Brien

Entries


My WishList
Resume
Want My Coffee?

Production

Photo Gallery
Articles
Podcasting
News

Amusements

Audio
Brewing
Cigars
Coffee
GPS/GeoCaching
Hacks
Home Theater
Kayak
Machine Shop
Photography
Recipes
SCUBA Diving

Research

CNC
CAD
Scripts
VR Interface
Environment
KarKomp
KarKompV2
MythTV

Reference

OWLNet
Quit Soda
Mac
Linux
Tech Ref
Panasonic Toughbook
Dreamhost hosting

Communication

Blackberry
T-mobile MDA
Danger Sidekick
WRT54G(s)

Transport

Land Rover
4Runner
Beetle
Jeeps
Motorcycles
EV Motorcycle
About
Links
Search

Juniper MX LAG to Cisco Nexus 7000 port channel

11 January, 2013 (09:20) | networking

I recently needed to set up some aggregated ethernet connections. (LAGs, Etherchannel, port channel, Agg, etc). In this case, it was between a Cisco Nexus 7k series switch and a Juniper MX 480 with trio based blades (MPC-2 to be exact). I did NOT configure this with multi-chassis technology – this is between single devices.

On the MX, you must enable aggregate ethernet interfaces. 100 is overkill, but this is actually from a MX960 in my lab. It’s upper limit is thousands.

set chassis aggregated-devices ethernet device-count 100

Without this, your new interface will never even appear in the interface list.

Now configure your first agg ethernet interface.

set interfaces ae0 description “test aggro port to lexus1″
set interfaces ae0 flexible-vlan-tagging
set interfaces ae0 mtu 9192
set interfaces ae0 encapsulation flexible-ethernet-services
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 unit 1234 encapsulation vlan-bridge
set interfaces ae0 unit 1234 vlan-id 1234

Note the vlan interface. I’m using bridge domains here. You don’t have to do it that way. Here’s the rest of the config for vlan 1234:

set interfaces irb unit 1234 description “test vlan for agg”
set interfaces irb unit 1234 family inet address 192.168.200.1/24

set bridge-domains vlan-1234 domain-type bridge
set bridge-domains vlan-1234 vlan-id 1234
set bridge-domains vlan-1234 interface ae0.1234
set bridge-domains vlan-1234 routing-interface irb.1234

That’s it for the MX configuration. This will work from MX to MX as well if you want a consistent LAG configuration. Now for the Nexus configuration.

Create a port channel:

interface port-channel1234
description “test agg link”
switchport mode trunk
switchport trunk allowed vlan 1234
spanning-tree port type normal
mtu 9216

Now configure and add the interfaces:

interface Ethernet1/3
description “link1 to mx”
switchport mode trunk
switchport trunk allowed vlan 1234
spanning-tree port type normal
mtu 9216
channel-group 1234 mode active
no shutdown

Note the mode active on the channel group. That forces active LACP. Also note the lack of VPC number in the port channel. That’s because it’s a single Nexus that’s not part of a VPC pair. I got burned on my original configuration because I’d left it in there. (Facepalm)

 

«

  »